package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:[.|,]\d{1,4})?$`)
var str = `151515.3443
dsfs
sdfsdfdsf
3422334.344
34343,3424
3424234.3423432423
.34324234
,34234
0.3434
0,455
23424334
34324.
324243,
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}