re = /^\d+(?:[.|,]\d{1,4})?$/m
str = '151515.3443
dsfs
sdfsdfdsf
3422334.344
34343,3424
3424234.3423432423
.34324234
,34234
0.3434
0,455
23424334
34324.
324243,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end