// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:[.|,]\d{1,4})?$").unwrap();
let string = "151515.3443
dsfs
sdfsdfdsf
3422334.344
34343,3424
3424234.3423432423
.34324234
,34234
0.3434
0,455
23424334
34324.
324243,
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}