import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:[.|,]\\d{1,4})?$";
final String string = "151515.3443\n"
+ "dsfs\n"
+ "sdfsdfdsf\n"
+ "3422334.344\n"
+ "34343,3424\n"
+ "3424234.3423432423\n"
+ ".34324234\n"
+ ",34234\n"
+ "0.3434\n"
+ "0,455\n"
+ "23424334\n"
+ "34324.\n"
+ "324243,\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}