const regex = /^\d+(?:[.|,]\d{1,4})?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(?:[.|,]\\d{1,4})?$', 'mg')
const str = `151515.3443
dsfs
sdfsdfdsf
3422334.344
34343,3424
3424234.3423432423
.34324234
,34234
0.3434
0,455
23424334
34324.
324243,
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}