import re
regex = re.compile(r"^\d+(?:[.|,]\d{1,4})?$", flags=re.MULTILINE)
test_str = ("151515.3443\n"
"dsfs\n"
"sdfsdfdsf\n"
"3422334.344\n"
"34343,3424\n"
"3424234.3423432423\n"
".34324234\n"
",34234\n"
"0.3434\n"
"0,455\n"
"23424334\n"
"34324.\n"
"324243,\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")