use strict;
my $str = '151515.3443
dsfs
sdfsdfdsf
3422334.344
34343,3424
3424234.3423432423
.34324234
,34234
0.3434
0,455
23424334
34324.
324243,
';
my $regex = qr/^\d+(?:[.|,]\d{1,4})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}