#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)b\d{4}\s[a-zA-Z]{3,4}(-\d)?"
Local $sString = "D b1308 pspE; thiosulfate sulfurtransferase PspE K03972 pspE; phage shock protein E" & @CRLF & _
"B 09193 Unclassified: signaling and cellular processes-6" & @CRLF & _
"C 99977 Transport" & @CRLF & _
"D b2347 yfdC; inner membrane protein YfdC K21990 yfdC; formate-nitrite transporter family protein" & @CRLF & _
"D b3657 yicJ; putative xyloside transporter YicJ K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family" & @CRLF & _
"D b3876 yihO; putative sulfoquinovose transporter K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family" & @CRLF & _
"D b0361 insD-1; IS2 element protein K07497 K07497; putative transposase" & @CRLF & _
"D b1402 insD-2; IS2 insertion element protein InsB K07497 K07497; putative transposase"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")