import re
regex = re.compile(r"b\d{4}\s[a-zA-Z]{3,4}(-\d)?", flags=re.MULTILINE)
test_str = ("D b1308 pspE; thiosulfate sulfurtransferase PspE K03972 pspE; phage shock protein E\n"
"B 09193 Unclassified: signaling and cellular processes-6\n"
"C 99977 Transport\n"
"D b2347 yfdC; inner membrane protein YfdC K21990 yfdC; formate-nitrite transporter family protein\n"
"D b3657 yicJ; putative xyloside transporter YicJ K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family\n"
"D b3876 yihO; putative sulfoquinovose transporter K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family\n"
"D b0361 insD-1; IS2 element protein K07497 K07497; putative transposase\n"
"D b1402 insD-2; IS2 insertion element protein InsB K07497 K07497; putative transposase")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")