using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"b\d{4}\s[a-zA-Z]{3,4}(-\d)?";
string input = @"D b1308 pspE; thiosulfate sulfurtransferase PspE K03972 pspE; phage shock protein E
B 09193 Unclassified: signaling and cellular processes-6
C 99977 Transport
D b2347 yfdC; inner membrane protein YfdC K21990 yfdC; formate-nitrite transporter family protein
D b3657 yicJ; putative xyloside transporter YicJ K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family
D b3876 yihO; putative sulfoquinovose transporter K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family
D b0361 insD-1; IS2 element protein K07497 K07497; putative transposase
D b1402 insD-2; IS2 insertion element protein InsB K07497 K07497; putative transposase";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}