const regex = /b\d{4}\s[a-zA-Z]{3,4}(-\d)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('b\\d{4}\\s[a-zA-Z]{3,4}(-\\d)?', 'gm')
const str = `D b1308 pspE; thiosulfate sulfurtransferase PspE K03972 pspE; phage shock protein E
B 09193 Unclassified: signaling and cellular processes-6
C 99977 Transport
D b2347 yfdC; inner membrane protein YfdC K21990 yfdC; formate-nitrite transporter family protein
D b3657 yicJ; putative xyloside transporter YicJ K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family
D b3876 yihO; putative sulfoquinovose transporter K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family
D b0361 insD-1; IS2 element protein K07497 K07497; putative transposase
D b1402 insD-2; IS2 insertion element protein InsB K07497 K07497; putative transposase`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}