import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "b\\d{4}\\s[a-zA-Z]{3,4}(-\\d)?";
final String string = "D b1308 pspE; thiosulfate sulfurtransferase PspE K03972 pspE; phage shock protein E\n"
+ "B 09193 Unclassified: signaling and cellular processes-6\n"
+ "C 99977 Transport\n"
+ "D b2347 yfdC; inner membrane protein YfdC K21990 yfdC; formate-nitrite transporter family protein\n"
+ "D b3657 yicJ; putative xyloside transporter YicJ K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family\n"
+ "D b3876 yihO; putative sulfoquinovose transporter K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family\n"
+ "D b0361 insD-1; IS2 element protein K07497 K07497; putative transposase\n"
+ "D b1402 insD-2; IS2 insertion element protein InsB K07497 K07497; putative transposase";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}