// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)b\d{4}\s[a-zA-Z]{3,4}(-\d)?").unwrap();
let string = "D b1308 pspE; thiosulfate sulfurtransferase PspE K03972 pspE; phage shock protein E
B 09193 Unclassified: signaling and cellular processes-6
C 99977 Transport
D b2347 yfdC; inner membrane protein YfdC K21990 yfdC; formate-nitrite transporter family protein
D b3657 yicJ; putative xyloside transporter YicJ K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family
D b3876 yihO; putative sulfoquinovose transporter K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family
D b0361 insD-1; IS2 element protein K07497 K07497; putative transposase
D b1402 insD-2; IS2 insertion element protein InsB K07497 K07497; putative transposase";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}