# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ ([0-9]+-[0-9]+)/\n\g<1>\n/gm;t' <<< " 1-1 test"