using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" ([0-9]+-[0-9]+)";
string substitution = @"\n\g<1>\n";
string input = @" 1-1 test";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}