package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) ([0-9]+-[0-9]+)`)
var str = ` 1-1 test`
var substitution = "\n\g<1>\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}