// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) ([0-9]+-[0-9]+)").unwrap();
let string = " 1-1 test";
let substitution = "\\n\\g<1>\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}