use strict;
my $str = ' 1-1 test';
my $regex = qr/ ([0-9]+-[0-9]+)/mp;
my $subst = '\\n\\g<1>\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";