import Foundation
let pattern = #" ([0-9]+-[0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" 1-1 test"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n\g<1>\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)