#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=Top)([\s\S]*?)(?=Bottom)"
Local $sString = "Top" & @CRLF & _
" Datum1" & @CRLF & _
" Datum2" & @CRLF & _
"Bottom" & @CRLF & _
" Datum 1" & @CRLF & _
" Datum 2" & @CRLF & _
"Top" & @CRLF & _
" Datum 1" & @CRLF & _
" Datum 2" & @CRLF & _
"Top" & @CRLF & _
" Datum1" & @CRLF & _
" Datum2" & @CRLF & _
"Bottom" & @CRLF & _
" Datum 1" & @CRLF & _
" Datum 2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")