const regex = /(?<=Top)([\s\S]*?)(?=Bottom)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Top)([\\s\\S]*?)(?=Bottom)', 'g')
const str = `Top
Datum1
Datum2
Bottom
Datum 1
Datum 2
Top
Datum 1
Datum 2
Top
Datum1
Datum2
Bottom
Datum 1
Datum 2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}