import re
regex = re.compile(r"(?<=Top)([\s\S]*?)(?=Bottom)")
test_str = ("Top\n"
" Datum1\n"
" Datum2\n"
"Bottom\n"
" Datum 1\n"
" Datum 2\n"
"Top\n"
" Datum 1\n"
" Datum 2\n"
"Top\n"
" Datum1\n"
" Datum2\n"
"Bottom\n"
" Datum 1\n"
" Datum 2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")