$re = '/(?<=Top)([\s\S]*?)(?=Bottom)/';
$str = 'Top
Datum1
Datum2
Bottom
Datum 1
Datum 2
Top
Datum 1
Datum 2
Top
Datum1
Datum2
Bottom
Datum 1
Datum 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);