re = /(?<=Top)([\s\S]*?)(?=Bottom)/
str = 'Top
Datum1
Datum2
Bottom
Datum 1
Datum 2
Top
Datum 1
Datum 2
Top
Datum1
Datum2
Bottom
Datum 1
Datum 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end