using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Top)([\s\S]*?)(?=Bottom)";
string input = @"Top
Datum1
Datum2
Bottom
Datum 1
Datum 2
Top
Datum 1
Datum 2
Top
Datum1
Datum2
Bottom
Datum 1
Datum 2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}