import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Top)([\\s\\S]*?)(?=Bottom)";
final String string = "Top\n"
+ " Datum1\n"
+ " Datum2\n"
+ "Bottom\n"
+ " Datum 1\n"
+ " Datum 2\n"
+ "Top\n"
+ " Datum 1\n"
+ " Datum 2\n"
+ "Top\n"
+ " Datum1\n"
+ " Datum2\n"
+ "Bottom\n"
+ " Datum 1\n"
+ " Datum 2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}