#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?<=smtp;) ?(\d{3})[ -]((?:\d+\.){2}\d+)"
Local $sString = "Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does..." & @CRLF & _
"Diagnostic-Code: smtp; 553 5.1.2 Unknown mail server. Could not find a mail server..." & @CRLF & _
"Diagnostic-Code: smtp; 550 5.5.0 Requested action not taken: mailbox unavailable..." & @CRLF & _
"Diagnostic-Code: smtp;550 5.5.0 Requested action not taken: mailbox unavailable..." & @CRLF & _
"Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does not exist..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")