use strict;
my $str = 'Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does...
Diagnostic-Code: smtp; 553 5.1.2 Unknown mail server. Could not find a mail server...
Diagnostic-Code: smtp; 550 5.5.0 Requested action not taken: mailbox unavailable...
Diagnostic-Code: smtp;550 5.5.0 Requested action not taken: mailbox unavailable...
Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does not exist...';
my $regex = qr~(?<=smtp;) ?(\d{3})[ -]((?:\d+\.){2}\d+)~imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}