const regex = new RegExp('(?<=smtp;) ?(\\d{3})[ -]((?:\\d+\\.){2}\\d+)', 'gim')
const str = `Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does...
Diagnostic-Code: smtp; 553 5.1.2 Unknown mail server. Could not find a mail server...
Diagnostic-Code: smtp; 550 5.5.0 Requested action not taken: mailbox unavailable...
Diagnostic-Code: smtp;550 5.5.0 Requested action not taken: mailbox unavailable...
Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does not exist...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}