import Foundation
let pattern = #"(?<=smtp;) ?(\d{3})[ -]((?:\d+\.){2}\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does...
Diagnostic-Code: smtp; 553 5.1.2 Unknown mail server. Could not find a mail server...
Diagnostic-Code: smtp; 550 5.5.0 Requested action not taken: mailbox unavailable...
Diagnostic-Code: smtp;550 5.5.0 Requested action not taken: mailbox unavailable...
Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does not exist...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)