using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=smtp;) ?(\d{3})[ -]((?:\d+\.){2}\d+)";
string input = @"Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does...
Diagnostic-Code: smtp; 553 5.1.2 Unknown mail server. Could not find a mail server...
Diagnostic-Code: smtp; 550 5.5.0 Requested action not taken: mailbox unavailable...
Diagnostic-Code: smtp;550 5.5.0 Requested action not taken: mailbox unavailable...
Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does not exist...";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}