$re = '~(?<=smtp;) ?(\d{3})[ -]((?:\d+\.){2}\d+)~im';
$str = 'Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does...
Diagnostic-Code: smtp; 553 5.1.2 Unknown mail server. Could not find a mail server...
Diagnostic-Code: smtp; 550 5.5.0 Requested action not taken: mailbox unavailable...
Diagnostic-Code: smtp;550 5.5.0 Requested action not taken: mailbox unavailable...
Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does not exist...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);