import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=smtp;) ?(\\d{3})[ -]((?:\\d+\\.){2}\\d+)";
final String string = "Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does...\n"
+ "Diagnostic-Code: smtp; 553 5.1.2 Unknown mail server. Could not find a mail server...\n"
+ "Diagnostic-Code: smtp; 550 5.5.0 Requested action not taken: mailbox unavailable...\n"
+ "Diagnostic-Code: smtp;550 5.5.0 Requested action not taken: mailbox unavailable...\n"
+ "Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does not exist...";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}