const regex = /(\{\{([^\}]+)\}\})\n\{\{\2\}\}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\{\\{([^\\}]+)\\}\\})\\n\\{\\{\\2\\}\\}', '')
const str = `===Verb===
{{eu-verb}}
{{eu-verb}}
test`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);