import re
regex = re.compile(r"(\{\{([^\}]+)\}\})\n\{\{\2\}\}")
test_str = ("===Verb===\n"
"{{eu-verb}}\n"
"{{eu-verb}}\n\n"
"test")
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)