use strict;
my $str = '===Verb===
{{eu-verb}}
{{eu-verb}}
test';
my $regex = qr/(\{\{([^\}]+)\}\})\n\{\{\2\}\}/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";