#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)dark:\w+([-:\w]*\w)"
Local $sString = "<button class="dark:text-white text-black">My Button</button>" & @CRLF & _
"<button class="text-black dark:text-white text-black">My Button</button>" & @CRLF & _
"<button class="text-black dark:text-white">My Button</button>" & @CRLF & _
"" & @CRLF & _
"<button class="[&[data-test]]:dark:text-white text-black">My Button</button>" & @CRLF & _
"<button class="text-black [&[data-test]]:dark:text-white text-black">My Button</button>" & @CRLF & _
"<button class="text-black [&[data-test]]:dark:text-white">My Button</button>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")