// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)dark:\w+([-:\w]*\w)").unwrap();
let string = "<button class=\"dark:text-white text-black\">My Button</button>
<button class=\"text-black dark:text-white text-black\">My Button</button>
<button class=\"text-black dark:text-white\">My Button</button>
<button class=\"[&[data-test]]:dark:text-white text-black\">My Button</button>
<button class=\"text-black [&[data-test]]:dark:text-white text-black\">My Button</button>
<button class=\"text-black [&[data-test]]:dark:text-white\">My Button</button>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}