import re
regex = re.compile(r"dark:\w+([-:\w]*\w)", flags=re.MULTILINE)
test_str = ("<button class=\"dark:text-white text-black\">My Button</button>\n"
"<button class=\"text-black dark:text-white text-black\">My Button</button>\n"
"<button class=\"text-black dark:text-white\">My Button</button>\n\n"
"<button class=\"[&[data-test]]:dark:text-white text-black\">My Button</button>\n"
"<button class=\"text-black [&[data-test]]:dark:text-white text-black\">My Button</button>\n"
"<button class=\"text-black [&[data-test]]:dark:text-white\">My Button</button>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")