$re = '/dark:\w+([-:\w]*\w)/m';
$str = '<button class="dark:text-white text-black">My Button</button>
<button class="text-black dark:text-white text-black">My Button</button>
<button class="text-black dark:text-white">My Button</button>
<button class="[&[data-test]]:dark:text-white text-black">My Button</button>
<button class="text-black [&[data-test]]:dark:text-white text-black">My Button</button>
<button class="text-black [&[data-test]]:dark:text-white">My Button</button>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);