import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "dark:\\w+([-:\\w]*\\w)";
final String string = "<button class=\"dark:text-white text-black\">My Button</button>\n"
+ "<button class=\"text-black dark:text-white text-black\">My Button</button>\n"
+ "<button class=\"text-black dark:text-white\">My Button</button>\n\n"
+ "<button class=\"[&[data-test]]:dark:text-white text-black\">My Button</button>\n"
+ "<button class=\"text-black [&[data-test]]:dark:text-white text-black\">My Button</button>\n"
+ "<button class=\"text-black [&[data-test]]:dark:text-white\">My Button</button>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}