# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$\d+/\n/gm;t' <<< "foo$12___bar___$34wilma buzz"