use strict;
my $str = 'foo$12___bar___$34wilma buzz';
my $regex = qr/\$\d+/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";