import Foundation
let pattern = #"\$\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"foo$12___bar___$34wilma buzz"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)