import re
regex = re.compile(r"\$\d+", flags=re.MULTILINE)
test_str = "foo$12___bar___$34wilma buzz"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)