package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$\d+`)
var str = `foo$12___bar___$34wilma buzz`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}