const regex = /\$\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\d+', 'gm')
const str = `foo\$12___bar___\$34wilma buzz`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);