# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\?[^?]*)+/$1/g;t' <<< "localhost.com/en_ar/body?abcd?products_type=235&treatment=132?product_type=235&treatment=132&__from_store=en_bh"