import re
regex = re.compile(r"(\?[^?]*)+")
test_str = "localhost.com/en_ar/body?abcd?products_type=235&treatment=132?product_type=235&treatment=132&__from_store=en_bh"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)