const regex = /(\?[^?]*)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\?[^?]*)+', 'g')
const str = `localhost.com/en_ar/body?abcd?products_type=235&treatment=132?product_type=235&treatment=132&__from_store=en_bh`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);